W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Discutez de tout ce qui a rapport avec MSTS, en général. Les trains, voitures, objet etc...

Modérateur : Modérateurs

Avatar du membre
nounours1952
Expert
Messages : 4123
Enregistré le : 30 nov. 2007 22:18
Localisation : LFSB
Contact :

W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar nounours1952 » 14 juin 2017 13:40

Bonjour,

si ça peut servir.

1 - dans Windows\SysWOS64x(ou System32 pour une machine 32 bits), rechercher "atiumdag.dll"
2 - Copier ce ficher et le coller dans le répertoire principal de "Train Similator"
3 - Télécharger "MSTS_AMD_BUGFIX.exe" sur "https://www.trainsim.com/vbts/showthread.php?322502-Will-Windows-10-support-AMD-graphic-card-in-MSTS/page2" (le lien se trouve dans le 6ème post de jackfuste, daté du 07-25-2015)
4 - lancer "MSTS_AMD_BUGFIX.exe" en lui indiquant le chemin du répertoire "Train Similator".

Chez moi ça a fonctionné à merveille sur une machine avec Windows 8.1.

Amicalement
L'homme ne se construit qu'en poursuivant ce qui le dépasse. (André Malraux)

Avatar du membre
CM63
Messages : 1834
Enregistré le : 13 août 2010 21:48
Localisation : Un peu au large de la faille de Limagne
Contact :

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar CM63 » 14 juin 2017 19:53

Bonjour,

Merci pour le tuyau .=
Image

Avatar du membre
Edouard78
Messages : 143
Enregistré le : 22 déc. 2012 9:49
Localisation : Entre 2 compresseurs

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar Edouard78 » 06 août 2017 9:35

Bonjour à tous et toutes !

C'est de nouveau moi avec mes problèmes qui ont avancé et je suis tout prêt du but même si...bah pas encore en fait ;= ...
Je poste ici car mon ordi est dôté d'un processeur graphique AMD R5 M430 sur Windows 10. Et les problèmes semblent venir de lui

ALORS, j'ai réussi à installer MSTS dans sa totalité avec les deux CD en laissant mouliner pendant des heures (2/3 heures ont suffi), MAIS l'archive .exe refusait de s'executer lorsque je cliquais dessus.

J'ai tripatouillé sur Google, vérifié les données dans mon Registre REGEDIT, RAS ou modification faite lorsque nécessaires. PUIS mise à jour de mes drivers de mon processeur graphique grâce à Drivers Cloud et installation du patch 1.4 MSTS depuis ASW.

ENFIN l'exe de MSTS s'ouvre sur un écran noir et...Retour au bureau illico ! Gros mystère, l'éditeur de mode lui s'ouvre convenablement mais pas le jeu <2< .
J'ai donc bien executé l'exe du jeu en mode de compatibilité Windows XP service pack 3, essayé en 640x680, mode de couleur réduit etc, rien ne change je suis toujours au même stade...
Ah et j'ai modifié le atumtiag.dll via le patch MSTS de ce post, toujours le même soucis... ;=

Quelqu'un a t il une autre solution ?
Ex-iledefrancemsts trainsimeur depuis 2006 (:

Avatar du membre
nounours1952
Expert
Messages : 4123
Enregistré le : 30 nov. 2007 22:18
Localisation : LFSB
Contact :

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar nounours1952 » 06 août 2017 10:37

Hello,

à tout hasard, as-tu essayé de faire toutes tes manips en mode administrateur ?

Amicalement
L'homme ne se construit qu'en poursuivant ce qui le dépasse. (André Malraux)

Avatar du membre
Edouard78
Messages : 143
Enregistré le : 22 déc. 2012 9:49
Localisation : Entre 2 compresseurs

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar Edouard78 » 06 août 2017 11:33

Salut !

Oui essayé aussi le résultat est le même, lancement, écran noir, windaube qui mouline et retour bureau... ,+
Ex-iledefrancemsts trainsimeur depuis 2006 (:

Avatar du membre
Edouard78
Messages : 143
Enregistré le : 22 déc. 2012 9:49
Localisation : Entre 2 compresseurs

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar Edouard78 » 12 août 2017 11:44

Bonjour bonjour ?

Personne n'a de solution ? ;=
Ex-iledefrancemsts trainsimeur depuis 2006 (:

Avatar du membre
nounours1952
Expert
Messages : 4123
Enregistré le : 30 nov. 2007 22:18
Localisation : LFSB
Contact :

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar nounours1952 » 12 août 2017 13:44

Hello,

si MSTS est installé correctement et que tu as bien suivi les consignes, tout devrait fonctionner normalement. Ce qui me laisse toutefois pensif, c'est que l'Editeur de modes fonctionne et pas MSTS. Cela manque un peu de logique si on se base sur tes informations, mais vu le temps que tu as mis pour l'installer (juste les deux CD), cela pourait expliquer ceci (ou l'inverse).

La seule idée qui me vient c'est de désintaller proprement MSTS et de le ré-installer ailleurs que dans c:\Programm Files (x86).

Le problème des CD qui ne s'installent plus correctement est récurrent. Avec beaucoup de chance, j'ai réussi à les copier sur mon DD et je fais l'installation depuis là. Pour l'instant, ça a toujours fonctionné.

Bonne chance
L'homme ne se construit qu'en poursuivant ce qui le dépasse. (André Malraux)

Avatar du membre
Edouard78
Messages : 143
Enregistré le : 22 déc. 2012 9:49
Localisation : Entre 2 compresseurs

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar Edouard78 » 19 août 2017 18:32

Salut salut !

Donc tu préconises de le ré-installer ailleurs que dans (x86) ou dans C:/ ...
Ex-iledefrancemsts trainsimeur depuis 2006 (:

Avatar du membre
nounours1952
Expert
Messages : 4123
Enregistré le : 30 nov. 2007 22:18
Localisation : LFSB
Contact :

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar nounours1952 » 19 août 2017 22:16

Hello,

sur une autre partition ou dans C:\Train Simulator, mais pas dans un répertoire de Windaube.

Amicalement
L'homme ne se construit qu'en poursuivant ce qui le dépasse. (André Malraux)

Avatar du membre
Edouard78
Messages : 143
Enregistré le : 22 déc. 2012 9:49
Localisation : Entre 2 compresseurs

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar Edouard78 » 20 août 2017 11:14

Bonjour bonjour !

Alors j'ai déplacer le dossier Train Simulator dans C:/ tout simplement et au lancement il me dit que le fichier est impossible à localiser ?, ...Faut il vraiment ré-installer tout le bazar ou je peux m'en sortir juste en résolvant le problème ci-dessus ?
Ex-iledefrancemsts trainsimeur depuis 2006 (:

Avatar du membre
Edouard78
Messages : 143
Enregistré le : 22 déc. 2012 9:49
Localisation : Entre 2 compresseurs

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar Edouard78 » 20 août 2017 12:07

Re et désolé pour le flood !

J'ai ré-installé MSTS dans un dossier propre bien à lui sur C:/ (Ca donne C:/Train Simulator...) ! Le tout sans bruit étrange du CD2 durant l'installation, ça a été super rapide un régal /nb

On en revient au problème de base cependant, rien ne se passe quand je clique sur l'icone que ce soit le .launcher ou le .train ... J'ai ré-installé la MAJ 1.4 depuis le site ASW et rebellote, écran noir lors du lancement et retour bureau ;. !
J'ai modifié les autorisations d'accès et de modifications sur le dossier de MSTS en me l’appropriant etc mais rien ne change ;= ...
Ex-iledefrancemsts trainsimeur depuis 2006 (:

Avatar du membre
nounours1952
Expert
Messages : 4123
Enregistré le : 30 nov. 2007 22:18
Localisation : LFSB
Contact :

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar nounours1952 » 20 août 2017 12:16

Hello,

alors là... je sèche pour l'instant. Laisse-moi le temps d'installer MSTS sur W10 pour pouvoir tester.

Amicalement
L'homme ne se construit qu'en poursuivant ce qui le dépasse. (André Malraux)

Avatar du membre
nounours1952
Expert
Messages : 4123
Enregistré le : 30 nov. 2007 22:18
Localisation : LFSB
Contact :

Re: W8/10 Comment faire fonctionner MSTS avec un processeur graphique AMD ?

Messagepar nounours1952 » 21 août 2017 14:05

Hello,

MSTS fonctionne très bien chez moi sous W10. Ceci dit, j'ai une carte graphique (basique) NVidia et non AMD.

Je ne me souviens pas si MSTS requiert "Microsoft NET Framework", mais s'il n'est pas installé, télécharge-le, il te sera au moins utile pour Open Rails.

Je n'ai pas d'autres idées à part les procédures basiques (mise à jour des pilotes - Driver Booster est excellent pour cela et gratuit).

Sinon, tu peux aussi comme dans "Qui veut gagner des millions" faire appel à un ami. En clair, il s'agit d'une assistance à distance par le logiciel "Teamviewer" (gratuit). Cette procédure permet à l'aidant de te guider dans la résolution des problèmes. Pour la partie vocale, j'utilise "Skype" (gratuit lui aussi). Si tu penses que ça peux t'intéresser, laisse-moi un MP. L'assistance est évidemment gratuite. (.

Amicalement
L'homme ne se construit qu'en poursuivant ce qui le dépasse. (André Malraux)


Retourner vers « MSTS: Général »