Page 1 sur 1

sons des compresseurs

Posté : 22 févr. 2018 16:25
par PK63
Bonjour,
pour l'instant le son compresseur se met en route sur une vitesse décroissante et presque à l'arrêt .or en fait les compresseurs fonctionnent plus souvent suite aux différentes consommations et fuites.j'avais résolu le problème en créant un random_trigger mais j'ai oublié que le fonctionnement a lieu meme si la loc n'est pas en service.y a til une solution pour que ces déclenchements ne ce fassent que disjoncteurs fermés?
Merci par avance.
a+

Re: sons des compresseurs

Posté : 27 févr. 2018 18:43
par trainagrandevitesse
Bonsoir Bernard,
Ce sont les trigger 12 (enclenchement) et 13(arrêt) qui gèrent le son du compresseur.
J'ai choisi d'utiliser ces trigger pour que l'on entende compresseur réellement lorsqu'il tourne.

Pour simuler les fuites et faire tourner le compresseur plus souvent, il 1 an de ça dans les anciennes versions de Openrails, il y avait une option avec la touche F9. On cliquait sur l'élément du train et sur la ligne "open/closed bleed of valve",ce qui créé une fuite lente à importante en fonction du nombre de valves ouvertes. Du coup on reproduisait facilement les fuites de la rame et le compresseur se lançait tout seul dés que la pression tombe sous un certain seuil.
Je parle dans le manuel de conduite des rames.

Mais maintenant ça fait chutter la pression des CF des engins sélectionnés, mais rien de plus.
A voir sur le forum de Elvas Tower...

A chercher...

Bonne soirée.

Re: sons des compresseurs

Posté : 28 févr. 2018 1:09
par V 150
Bonsoir Bernard,

Pour compléter la réponse de Jean-Prisca, voici un exemple du script dont je me sers pour le compresseur de mes engins (ici avec l'exemple des Z5600, je tiens les pistes sonores à ta disposition si tu veux en savoir plus).

Code : Tout sélectionner

         Stream (
            Skip ( **** Lancement compresseur **** )
            Priority ( 6 )
            Triggers ( 4
               Discrete_Trigger ( 12
                  StartLoopRelease ( 1
                     File ( "Compresseur_Z5600.wav" -1 )
                  SelectionMethod ( SequentialSelection )
                  )
               )
               Discrete_Trigger ( 13
                  ReleaseLoopReleaseWithJump ( )
               )
               Discrete_Trigger ( 13
                  SetStreamVolume ( 0.0 )
               )
               Discrete_Trigger ( 13
                  SetStreamVolume ( 1.0 )
               )
            )
         )
         
         Stream (
            Skip ( **** Arrêt compresseur **** )
            Priority ( 6 )
            Triggers ( 1
               Discrete_Trigger ( 13
                  PlayOneShot ( 1
                     File ( "Arret_Compresseur_Z5600.wav" -1 )
                  SelectionMethod ( SequentialSelection )
                  )
               )
            )
         )


Ce qui donne approximativement ceci (à 1 min 36) :



Et pour les fuites, il y a une ligne à insérer dans le fichier .eng de la machine équipée du compresseur, au niveau des paramètres de frein. Elle permet de modéliser la fuite d'air dans les conduites. Je n'ai pas encore compris comment fonctionne le coefficient, mais avec la valeur ci-dessous, on arrive à un déclenchement en moyenne toutes les 7 à 8 minutes sur une composition BB17000+VB2N, ce qui correspond à la réalité (valeur si on ne touche pas au manipulateur de frein dans cet intervalle, sinon c'est évidemment plus souvent en fonction de la sollicitation du frein pneumatique).

Code : Tout sélectionner

TrainPipeLeakRate ( 7 )


Bonne soirée,

Amicalement,
Vladimir.

Re: sons des compresseurs

Posté : 02 mars 2018 18:15
par PK63
Bonsoir,
merci a tous les 2 pour votre réponse. J'ai installé comme cité cidessus le son compresseur des Cc6500 et BB22200 . malheureusement rien ne fonctionne .avec les cc6500 le son se met en marche une 30taine de seconde après le fermeture des disjoncteurs mais tourne en boucle . sitôt arrêter ca redemarre et si on ouvre les disjoncteurs sa continue quand même. Sachant que si j'enlève la ligne trainpipeleakrate je ne l'entends pas du tout.
Pour les BB22200ca ne fonctionne pas du tout.
je ne comprend pas pourquoi ca ne se passe pas pareil et pourquoi ca ne fonctionne pas chez moi.je ne pense pas que cela viennent des .wav
bon weekend
a+

Re: sons des compresseurs

Posté : 31 mars 2018 11:08
par PK63
Bonjour,
applaus001 a vous deux.j'ai reussi à avoir le son des compresseurs.en ajoutant la ligne citee plus haut par V150 et comme dis dans un autre post en remplacant single pipe par twin pipe la pression chute régulièrement il suffit de regler le pression mini et la pression maxi dans la partie airbrakes.
merci encore
a+