Route Fi-Pi-Li-Si-2007 probleme de shapes [résolu]

Description des itinéraires existants.

Modérateur : Modérateurs

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Route Fi-Pi-Li-Si-2007 probleme de shapes [résolu]

Messagepar Sud » 27 oct. 2015 17:07

Bonjour à tous, <1<

Je viens d’installer la ligne Italienne ci dessus, comme je fais d'habitude je la passe a RR et je démarre en mode exploration.
Départ de Firenze direction Livorno avant la première gare j'ai trois messages concernant des fichiers de textures il me semble,
Bon en soit je peut continuer mais il faut que je clic 3* sur ok, est ce des fichiers corrompus ou manquants?
Merci de votre aide et bonne fin de journée..... /nb
P.S ci joint le détails des fichiers.........................> http://dl.free.fr/gpkPomQua
Modifié en dernier par tgvbreizh le 05 nov. 2015 10:13, modifié 1 fois.
Raison : sujet résolu et modification du titre à la demande de michel
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”

Avatar du membre
XylonAkau
Messages : 1936
Enregistré le : 24 juil. 2010 8:49
Localisation : Taputapuatea (ISLV)
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar XylonAkau » 27 oct. 2015 19:44

___Ia ora na.
___Le premier écran (1.docx) indique que les fichiers .s et .sd sont attendus dans un répertoire \Global\Track_B\Shapes~2 (si l'objet est bien déclaré comme TrackObj ; difficile de lire, dans Shapes~2, s'il s'agit d'un tiret ou d'un tilde) ; les deux autres disent à peu près la même chose, mais il doit y avoir un problème dans l'énoncé de la redirection. Quant au rapport de RouteRiter, ses trois premières lignes peuvent traduire la même situation, puisque le programme ne reconnaît pas les redirections.
___Il est probable que ces fichiers se trouvent dans l'archive de la ligne (ou dans un ajout ?), et la documentation devrait indiquer comment les mettre en place. Sinon, il faudrait voir dans le fichier .w correspondant.
___Comme le problème est directement lié à cette ligne, j'ai déplacé le sujet dans la rubrique des Itinéraires.
___Pour les deux dernières lignes du rapport de RR, en effet, il manque aux deux fichiers mentionnés la ligne

Code : Tout sélectionner

ESD_Alternative_Texture ( 0 )
___Cela ne devrait pas perturber MSTS, mais tu peux la rajouter si tu veux faire plaisir à RouteRiter.
___Bon courage et bonne solution.

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar Sud » 29 oct. 2015 9:25

Bonjour à tous, /nb

Merci XylonAkau pour ta réponse (excuse le retard mais hier je n'arrivais pas a accéder au forum) je vais donc faire
comme tu dis, si ça fonctionne pas tant pis..........
Bonne journée... <1<
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”

Avatar du membre
XylonAkau
Messages : 1936
Enregistré le : 24 juil. 2010 8:49
Localisation : Taputapuatea (ISLV)
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar XylonAkau » 30 oct. 2015 8:25

___Ia ora na.
Sud a écrit :hier je n'arrivais pas a accéder au forum
___Si cela peut te rassurer, tu n'étais pas le seul.
___Pour revenir à ton problème,
1) les trois captures d'écran de MSTS affichent un message d'erreur pour la même section de voie : A1tPnt3dBRgtMnl.s, mais sous deux formes différentes ; pour corriger la première erreur, il doit suffire de copier les deux fichiers A1tPnt3dBRgtMnl.s et A1tPnt3dBRgtMnl.sd dans un répertoire \Global\Track_B\Shapes-2, mais il n'est pas sûr que cela suffise à supprimer les deux autres messages d'erreur ; il faudrait alors modifier la ligne FileName ( du (ou des) fichier(s) .w en cause.
2) la capture de RR indique cinq erreurs :
- celle que tu as signalée précédemment,
- sans doute la même pour deux fichiers A2t500mStrt et A3t500r5d (dans d'autres parcelles),
- plus les deux lignes ESD_Alternative_Texture manquantes.
___Tout peut être corrigé, mais plus ou moins facilement. A toi de voir quand le jeu te paraît en valoir la chandelle.
___Bonne suite, en tous cas.

Post-scriptum (simple suggestion) : des images .jpg ou même .png sont moins lourdes et plus faciles à manier que des pages .docx.
Post^2-scriptum : voir plus bas une solution plus simple et plus rapide.

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar Sud » 30 oct. 2015 9:10

Bonjour à tous, /nb

Merci XylonAkau pour ta réponse bien détaillée vu la manipulation je crois que je vais laisser dans l’état actuel <2<
En ce qui concerne les images c'est noté.
Bonne journée à tous..... <1<
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”

Avatar du membre
XylonAkau
Messages : 1936
Enregistré le : 24 juil. 2010 8:49
Localisation : Taputapuatea (ISLV)
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar XylonAkau » 03 nov. 2015 6:26

___Ia ora na fa'ahou.
___Après une visite sur les lieux, le problème des trois messages d'erreur semble assez facile à résoudre : il faut seulement
1) ouvrir le fichier w-005732+014526.w (il est déjà décompressé, comme une bonne partie de ses semblables) ;
2) chercher la chaîne ../, ce qui mène à

Code : Tout sélectionner

   TrackObj (
      UiD ( 2947 )
      SectionIdx ( 38051 )
      Elevation ( 0 )
      JNodePosn ( -5732 14526 891.019 55.0206 -820.233 )
      CollideFlags ( 583 )
      FileName ( ../TRACK_B/SHAPES-2/A1tPnt3dBRgtMnl.s )
      StaticFlags ( 00200180 )
      Position ( 891.019 55.0206 -820.233 )
      QDirection ( 0 0.165078 0 0.986281 )
      VDbId ( 4294967294 )
      StaticDetailLevel ( 0 )
   )
3) dans la section ci-dessus, à la ligne FileName, supprimer ../TRACK_B/SHAPES-2/ pour ne garder que A1tPnt3dBRgtMnl.s.
___Cela a suffi pour faire disparaître les trois messages d'erreur de MSTS.
NB- il est alors possible de compiler/compresser le fichier .w (ainsi que les quatre-vingts autres qui sont comme lui).
___Buoni viaggi con MSTS.

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar Sud » 04 nov. 2015 11:22

Bonjour à tous, /nb

Pfoufff facile?.... confused19 merci beaucoup XylonAkau ou vas tu chercher tout cela??? et en plus ça fonctionne..
Encore merci et bonne journée.... .=
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”

Avatar du membre
XylonAkau
Messages : 1936
Enregistré le : 24 juil. 2010 8:49
Localisation : Taputapuatea (ISLV)
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar XylonAkau » 04 nov. 2015 23:10

___Ia ora na 'a.
___Heureux de savoir que cela a aussi fonctionné chez toi. Tu peux donc éditer le message initial et ajouter [Résolu] dans le titre.
___Bon courage pour la suite.

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....Résolu

Messagepar Sud » 05 nov. 2015 9:14

Sud a écrit :Bonjour à tous, <1<

Je viens d’installer la ligne Italienne ci dessus, comme je fais d'habitude je la passe a RR et je démarre en mode exploration.
Départ de Firenze direction Livorno avant la première gare j'ai trois messages concernant des fichiers de textures il me semble,
Bon en soit je peut continuer mais il faut que je clic 3* sur ok, est ce des fichiers corrompus ou manquants?
Merci de votre aide et bonne fin de journée..... /nb
P.S ci joint le détails des fichiers.........................> http://dl.free.fr/gpkPomQua
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar Sud » 05 nov. 2015 9:21

Bonjour à tous, /nb

Je trouve pas le bouton éditer dans mon premier post ?+ pour écrire résolu......désolé =, ...........
Bonne journée.... <1<
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”

Avatar du membre
tgvbreizh
Modérateur
Messages : 2616
Enregistré le : 15 nov. 2004 19:54
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes....

Messagepar tgvbreizh » 05 nov. 2015 10:14

Sud a écrit :Bonjour à tous, /nb

Je trouve pas le bouton éditer dans mon premier post ?+ pour écrire résolu......désolé =, ...........
Bonne journée.... <1<

bonjour michel c'est fait et suppression d'un message en doublon
bonne journée
Membre de l apsfi et modérateur rubrique activité sur asw et membre des compagnons du rail

http://compagnonsdurail.wix.com/creations
créateur de la BZH1985 et de Brest /Rennes
Image
Image
breizhamicalement

Avatar du membre
Sud
Messages : 1010
Enregistré le : 30 avr. 2009 9:03
Localisation : un petit coin de lorraine
Contact :

Re: Route Fi-Pi-Li-Si-2007 probleme de shapes [résolu]

Messagepar Sud » 05 nov. 2015 15:40

Bonjour à tous, /nb

Merci tgvbreizh et tant que je te tiens félicitations pour les deux belles lignes bretonnes que tu as mis a disposition de la communauté applaus001 .....
Bonne journée à tous ....
amitiés Michel.

“Certains esprits sont des trains qui vont si vite qu'on n'a pas le temps de s'apercevoir qu'ils sont vides.”


Retourner vers « MSTS: Les itinéraires »