Un point (ou un poing ?) sur Conbuilder

Vous avez un problème avec un autre utilitaire, venez l'exposer ici.

Modérateur : Modérateurs

bjpaul
Messages : 612
Enregistré le : 26 août 2007 10:17
Localisation : Val d'Oise

Un point (ou un poing ?) sur Conbuilder

Messagepar bjpaul » 26 janv. 2016 23:32

Bonsoir les amis,
(Ce sujet vaut aussi pour OR, bien sûr)
Hou là... Mais de quoi un vieux marsouin de MSTS (même converti à OR..) veut-il nous entretenir ??? Voilà l'histoire... J'utilise, depuis 11 ans (déjà...) la même version de Conbuilder (2.3.28), alors freeware (eh oui, les jeunes, ça a existé, des freewares américains !). Sans problèmes, il faut le dire.. Conbuilder était un logiciel qui, à défaut d'être folichon, faisait son boulot avec discrétion, rigueur et efficacité. Bon, mais... Les add-ons se sont empilés, et même si mes DD externes débordent de "Trainset" réformés (en attendant le jour où, on ne sait jamais... (. On est tous pareils, non ?), vient toujours le moment où Conbuilder vous dit qu'il a "les dents du fond qui baignent" et que ça se bouscule à la sortie du dépôt.
Bon, je sais que je suis pas malin, mais je me suis dit, même payware, je peux, au bout de dix ans, me payer l'évolution de ce logiciel si discret, mais si utile... Je sais, y'a "Convoi", les "torrents" sur le Net, bref, faut être c.. pour mettre une thune dans ce genre d'achats, mais voilà : et d'une j'ai mes habitudes, et de deux, c'est presque moral de payer pour une douzaine d'années de bons et loyaux services, non ?
Bref, je suis allé sur le site de Conbuilder, et j'ai acheté la dernière version - 5.8.2 ! 30 $... Thirty bucks, comme on dit là-bas ! A ce prix-là, ça doit être bien ! D'abord, c'est simple de payer, mais pour avoir un logiciel opérationnel, c'est pas pareil !!! Conbuilder est à mon avis, mieux défendu contre le piratage que la liste des comptes secrets de (censuré) en Suisse ! Faut envoyer un mail, puis un autre, attendre une nuit pour recevoir la licence qui permet de l'exécuter.. Laquelle n'est valable qu'une fois (si on en veut réinstaller, faut redemander ! Une troisième fois, faut un courrier du Pape... Curieuse notion de la "licence"...). L'installation se passe bien, qui débouche sur un logiciel ressemblant étrangement à son arrière-grand-père d'il y a douze ans. Il y a certainement des "plus", mais ils ne sautent pas aux yeux !!!
Fonctionnement sans bavures, apparemment.. Apparemment seulement, parce qu'à la première sauvegarde d'un nouveau Consist, apparaît un message d'erreur (du genre pas clair : "RunTime Error "13" : mismatch") et ziouppp ! le logiciel s'évapore ! 15 ans de TS me laissent serein par rapport à l'anicroche : je vérifie les .eng et wag, modifie, égalise, bidouille, mais rien n'y fait.
J'analyse le fichier incriminé à l'aide de ConBuilder, qui me déclare ne pas trouver le FreightAnim associé, pourtant bien présent.. J'essaie, sur une intuition, d'autres fichiers incluant des FA (3 ou 4000 dans mon Trainset...pas tous essayés quand même ! ;/ ), pour constater que CB 5.8.2 est allergique aux FreightAnim ! Je contacte le support de Conbuilder qui me demande quelques (enfin, plutôt des tas...) de précisions (en plus, je ne me rappelais plus de la date de ma première communion...). Sympa, le support de Conbuilder, si, si !!! Dévoué, au moins, sachant que le dévouement ne remplace pas forcément la compétence... Après huit échanges de mail, il ressort que :
- Conbuilder ne fonctionne plus avec une syntaxe autre qu'américaine (223.5 kN, et non 223,5... A noter toutefois que tous mes fichiers .eng sont pourtant - comme les vôtres - rédigés en respectant cette écriture anglo-saxonne). Pourquoi, dur à dire, puisque le logiciel ne lit, en principe, que des fichiers rédigés selon cette syntaxe : peu lui chaut que mes courriers et tableurs soient configurés "français", a priori... Ben non : une fois mon Windows configuré "US Style", je parviens à sauvegarder mes consists !
- En théorie, MSTS ne doit pas être installé en C:\Program Files (x86), ni en C:\Program Files. Sachant que Conbuilder ne peut pas être dans le même répertoire que MSTS, j'ai un moment songé à le mettre sur le buffet du salon... En fait, là, j'ai rien changé, et ça marche quand même
- Peut-être, mais c'est pas sûr (sic...) qu'on devrait, pour les FreightAnim, mettre des guillemets au nom du fichier. Dès que j'aurais trois semaines de congés pour modifier les 6892 fichiers concernés, promis, j'essaie !
Bon, là, ça marche, il est 11:17 PM et on est le 1/26/16 (faut que j'm'y fasse !!!). Néanmoins, les rapports affichent toujours le FA manquant, mais je m'en fous, pour être franc ! Quant à la différence avec le 2.8.23, elle est évidente : le numéro de version !!!
Pour mémoire, la version 2.8.23 quoique pré-adolescente (11 ans déjà) acceptait toutes les syntaxes, et trouvait tous les FA sans le moindre problème. En plus, on l'installait sans avoir à subir une fouille avec toucher rectal...
J'ai expliqué, dans mon anglais shakespearien, aux trois "créateurs", qu'il eut peut-être mieux valu passer un petit peu du temps qu'ils ont consacré à développer une inviolabilité digne du Mur de Berlin à développer le logiciel et surtout, ne pas lui retirer son "universalité" et sa facilité d'usage, tout en les assurant que je ferais part aux simmers d'outre-Atlantique de ma pensée profonde sur leur réalisation (ou plutôt ce qu'ils en ont fait...). Et je n'ai qu'une parole ! Laquelle vaut bien 30 $.
Ah !!! Ca fait du bien !!! /nb
Bonne soirée ! et amitiés !
Jean-Paul
PS : si vous cherchez ConBuilder 2.8.23, faites-moi signe ! (Hé, quoi ? C'était un freeware, non ?). Il marche très bien, finalement !

Retourner vers « MSTS: Autres utilitaires »